SemanticLayerAgent service stops immediatly after upgrading BusinnessObjects SupportPackage
Condition
After upgrading BusinessObjects from SupportPackage x to SupportPackageX+1 when you start 360SemanticLayerAgent Service it immediately stops.
If you open stdout.log file in the semantic-layer-agent/logs folder you find
- Error occurred during initialization of VM
- java/lang/NoClassDefFoundError: java/lang/Object
Environment
The issue was observed with those upgrade schemas:
- From BI 4.2 SP6 to BI4.2 SP8
- From BI 4.2 SP6 to BI4.2 SP9
- From BI 4.2 SP8 to BI4.2 SP9
Solution
Cause
The default architecture of sapjvm has changed and 32bits architecture is not completely deployed on your installation
Remedy
- Ensure you have at least 360WebPlatform 2022.2 version
- Go to your 360WebPlatform installation directory
- Double Click on 360SLA Configuration shortcut
- Go to "startup" tab and in the parameters field enter --use64bits
- You can then restart the service
Last updated over 2 years ago