Database Debug Mode (on Microsoft Windows)

Condition

Database issues arise and detailed logs are needed for debugging and fixing problems.

Solution

Cause

The database may be corrupted or other technical issues arise.

Remedy

1. Open a Windows command line or PowerShell prompt.
2. Access the location of the 360Suite service or Apache Tomcat server executable:
%programfiles[(x86)]%\<360Suite_install_dir>
or
<Tomcat_install_dir>\Tomcat<version>\bin

3. Enter the following command (where service_name must match the 360Suite service name specified at installation time):
tomcat9w.exe//ES//<service_name>

4. The service properties window opens. Click on the “Java“ tab and append the following option (new line) to the existing list in the “Java Options“ field:
-Dwp.database.debug=true

5. Click on “Apply“, then on “Ok“ to save the changes.
6. If applicable, restart the Apache Tomcat server.

Last updated about 2 years ago