When exporting a unx, receive error "Semantic Layer Agent unavailable, make sure that it is properly started on the server: sla001"

Symptom

When trying to export a UNX, export fails and Display log option shows the following error message: 
"Semantic Layer Agent unavailable, make sure that it is properly started on the server : sla001
Could not retrieve data : Semantic Layer Agent unavailable, make sure that it is properly started on the server"


Environment

  • 360Suite Web Platform
  • 360Univ

Reproducing the issue

  1. Connect to the 360Suite Web Platform.
  2. Go to Universe Management.
  3. Select a universe and click Export.
  4. The error message occurs.

Cause

This is caused because the Semantic Layer Agent is not running on the server where 360 Web Platform is installed.

Resolution

The Semantic Layer Agent must be deployed as part of the 360Suite installation in order to use 360Univ universe management.

  1. Navigate to its location, which depends on the installed version:
    1. For 360 Web Platform for BI 4.1: <%windir%>\360Suite410
    2. For 360 Web Platform for BI 4.2: <%windir%>\360Suite425
  2. Run the following command: java -jar Launcher.jar [-p:<port>]
    -
    p allows specifying a custom port, as the default is 1338. For example: java -jar Launcher.jar -p 1339
    If using a custom port, then this port number needs to be specified in the Administration Console > Technical Settings > RMI settings.
  3.  A command prompt window opens and a message is displayed to indicate the agent is running. The agent is active as long as the command line remains open.

Keywords

SLA

See Also

360 Web Platform installation guide: https://support.360suite.io/download/file/162

Product

Product or Product version
  • 360Univ Web Platform

Languages

  • English US
  • English UK
  • French

Last updated over 4 years ago