HTTP Status 400 Bad request when trying to interact with scheduled tasks
Symptom
After a Tomcat update/change, the 360Suite Legacy application displays the following error message when trying to create a new scheduled task or update an existing one:
Environment
- 360Suite Web Platform
- 360Suite Legacy
- SAP BusinessObjects Business Intelligence 4.1
- SAP BusinessObjects Business Intelligence 4.2
Reproducing the issue
- Log into 360Suite Legacy 360Bind or 360View.
- Navigate to the Schedules tab.
- Update an existing task.
Cause
This issue is caused by a patch for Tomcat 8/8.5/9 that restricts the list of available characters in URLs by default.
Resolution
- Open the file called server.xml located under: <tomcat>/conf/
- Find the <Connector> tag in the file.
- Add the following line before the end of the tag:
relaxedPathChars="[/" relaxedQueryChars="[/" - Save the file.
- Restart Tomcat.
See below for an example:
Keywords
HTTP 400, 360view, 360bind, schedules, exist, current, legacy, application
Product
Product or Product version
- 360View
- 360Bind
- 360Cast
- 360Plus
Languages
- English US
- English UK
- French
Last updated about 5 years ago