HTTP Status 400 Bad request when trying to interact with scheduled tasks

Symptom

After a Tomcat update/change, the 360Suite Legacy application displays the following error message when trying to create a new scheduled task or update an existing one:


Environment

  • 360Suite Web Platform
  • 360Suite Legacy
  • SAP BusinessObjects Business Intelligence 4.1
  • SAP BusinessObjects Business Intelligence 4.2


Reproducing the issue

  1. Log into 360Suite Legacy 360Bind or 360View.
  2. Navigate to the Schedules tab.
  3. Update an existing task.

Cause

This issue is caused by a patch for Tomcat 8/8.5/9 that restricts the list of available characters in URLs by default.

Resolution

  1. Open the file called server.xml located under: <tomcat>/conf/
  2. Find the <Connector> tag in the file.
  3. Add the following line before the end of the tag:
    relaxedPathChars="[/" relaxedQueryChars="[/"
  4. Save the file.
  5. Restart Tomcat.
See below for an example:



Keywords

HTTP 400, 360view, 360bind, schedules, exist, current, legacy, application

Product

Product or Product version


  • 360View
  • 360Bind
  • 360Cast
  • 360Plus

Languages

  • English US
  • English UK
  • French


Last updated over 4 years ago