"Unexpected error : java.lang.RuntimeException: Failed to load... <connection name>.cns" when exporting unx in 360Univ Web Platform

Symptom

Error when exporting an universe: "Unexpected error : java.lang.RuntimeException: Failed to load C:\Program Files (x86)\360.suite\apache-tomcat-8.0.39\temp\SdkSlAuth20190131173728_4c8aa55cba0b4592\<connection name>.cns". 
Error occurs when 360Univ is installed on a dedicated server, not on a server where Business Objects is installed.

Environment

  • 360Suite Web Platform
  • 360Univ

Reproducing the issue

  1. Connect to the 360Suite Web Platform.
  2. Go to 360Univ.
  3. Select a universe and click Export.
  4. The error message after processing.

Cause

This is caused because 360Univ works in 64-bit and the 64-bit SL SDK is only shipped with the Business Objects SIA installations.

Resolution

After installing the SL SDK through the BOBJ Client tools, copy the <Business Objects>\SAP BusinessObjects Enterprise 4.0\win64_x64 folder of the BOBJ CMS Server to <Business Objects>\SAP BusinessObjects Enterprise 4.0 on the 360Suite Web Platform server.

Note: You will be able to interact with unx universes in the 360Univ module of the 360Suite Web Platform that are NOT based on ODBC connections. If your unx universe is based on an ODBC connection, you will have to use the 360Univ rich client. 

Keywords

WP, unexpected error, SDK, failed to load connection

Product

Product or Product version
  • 360Univ Web Platform

Languages

  • English US
  • English UK
  • French

Last updated over 5 years ago