How to fix the 'WEAK link' issue
Symptom
How to relink a document to a universe when encountering a "weak link" issue?
Environment
- 360Eyes
- SAP BusinessObjects Enterprise XI 3.1
- SAP BusinessObjects Business Intelligence 4.0
- SAP BusinessObjects Business Intelligence 4.1
- SAP BusinessObjects Business Intelligence 4.2
- SAP BusinessObjects Business Intelligence 4.3
Cause
This issue is arises when the universe CUID stored in the WEBI report does not match any existing universe CUID on the platform.
A change of universe CUID may be the result of a possibly incorrect migration process (based on name instead of ID).
This is not a 360Eyes issue, but a valid link between the document and the new universe CUID can be restored.
Resolution
In order to solve the issue, proceed as follows:
- Open the document in Edit mode.
- Go to the Query Panel / Properties.
- Select the universe to relink, and select the same universe it was previously linked to from the "Available universes" section (not from the "Used universes" section).
- Confirm the selection and save the report.
- Launch 360Eyes WEBI again (the WEAK link error should no longer be raised for this specific report).
Keywords
report, Webi, weak link
Product
Product or Product version
- 360Eyes
Languages
- English
Last updated over 2 years ago